Contact storage outage
Incident Report for FullContact
Resolved
This incident has been resolved.
Posted May 13, 2019 - 16:10 MDT
Update
We are continuing to investigate this issue.
Posted May 13, 2019 - 16:09 MDT
Investigating
We are currently investigating this issue.
Posted May 13, 2019 - 08:56 MDT
This incident affected: Contacts API and Apps.