Contact Synchronization delayed
Incident Report for FullContact
Resolved
This incident has been resolved.
Posted Aug 11, 2019 - 01:38 MDT
Investigating
We are currently investigating this issue.
Posted Aug 11, 2019 - 00:41 MDT