Contact synchronization delayed
Incident Report for FullContact
Resolved
This incident has been resolved.
Posted Mar 04, 2019 - 01:57 MST
Investigating
We are currently investigating this issue.
Posted Mar 03, 2019 - 19:42 MST
This incident affected: Apps.