Contact sync with Xing is currently disabled
Incident Report for FullContact
Resolved
Feature temporarily removed
Posted Nov 29, 2018 - 13:03 MST
Investigating
We are currently investigating this issue.
Posted Oct 22, 2018 - 06:27 MDT
This incident affected: Apps.